RecoveryLink 2.0 - Data Saving Issue
Incident Report for RecoveryLink
Resolved
This incident has been resolved.
Posted Jun 15, 2023 - 19:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 15, 2023 - 15:23 UTC
Investigating
We are currently investigating a critical issue that is preventing content from being saved in RecoveryLink 2.0 (legacy is not impacted at this time).
Posted Jun 15, 2023 - 13:42 UTC
This incident affected: Electronic Recovery Record.