RecoveryLink ERR Intermittent Login Issues
Incident Report for RecoveryLink
Resolved
RecoveryLink engineers have identified an issue with the cloud hosting provider that is affecting certain authentication processes for user accounts. The team will be monitoring the updates being made by the provider to resolve the reported issue.
Posted Nov 15, 2023 - 23:25 UTC
Investigating
Our engineers are currently investigating reports of intermittent login issues by some RecoveryLink application users.
Posted Nov 15, 2023 - 21:33 UTC
This incident affected: Electronic Recovery Record.