RecoveryLink ERR Application Login Issues
Incident Report for RecoveryLink
Resolved
This incident has been resolved. RecoveryLink engineers will continue to monitor updates for any status changes.
Posted Oct 10, 2023 - 17:01 UTC
Monitoring
RecoveryLink engineers are monitoring issue updates. ERR application login corrected in testing.
Posted Oct 10, 2023 - 15:01 UTC
Update
Our engineers are seeing partial resolution to login function and are still investigating initial cause for any service disruption.
Posted Oct 10, 2023 - 14:44 UTC
Investigating
Our engineers are currently investigating reports of general login issues for the ERR application. Updates will be posted throughout our review.
Posted Oct 10, 2023 - 14:37 UTC
This incident affected: Electronic Recovery Record.