Partner Site (Pantheon) Experiencing Infrastructure Issues
Incident Report for RecoveryLink
Resolved
This incident has been resolved.
Posted Jun 16, 2021 - 19:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2021 - 19:18 UTC
Investigating
We are currently working with our partner to investigate the issue.
Posted Jun 16, 2021 - 19:05 UTC
This incident affected: Electronic Recovery Record.