Electronic Recovery Record Record Saving Issue
Incident Report for RecoveryLink
Resolved
We have resolved an issue that is preventing saving of several types of records in the electronic recovery record platform. This update will continue to be monitored.
Posted May 13, 2022 - 14:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 13, 2022 - 14:34 UTC
Investigating
We are currently investigating an issue that is preventing saving of several types of records in the electronic recovery record platform.
Posted May 13, 2022 - 13:35 UTC
This incident affected: Electronic Recovery Record.