Staging + Testing Applications Access
Incident Report for RecoveryLink
Resolved
An issue with DNS records was the cause of this issue. This incident has been resolved and all staging and testing versions of the application are now fully operational.
Posted Dec 14, 2020 - 16:58 UTC
Investigating
We are currently investigating this issue.
Posted Dec 14, 2020 - 15:18 UTC