Partial Outage - Sign On Core Application
Incident Report for RecoveryLink
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 00:33 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 11, 2024 - 23:26 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 11, 2024 - 23:26 UTC
This incident affected: Electronic Recovery Record.